Intermittent Insights Issues
Incident Report for Energage
Resolved
This incident has been resolved.
Posted Oct 25, 2023 - 10:25 EDT
Investigating
We are currently investigating an issue affecting access to the Energage platform intermittently. If you encounter an issue, please email support@energage.com. Thank you for your patience!
Posted Oct 25, 2023 - 09:40 EDT
This incident affected: Employee Survey and Energage Login.