Platform Connection Errors

Incident Report for Energage

Resolved

Our authentication provider has implemented a fix, and we are seeing the Energage Platform return to normal. This outage has been resolved. If you are seeing any issues within the platform, don't hesitate to get in touch with support@energage.com or your dedicated resource.
Posted Jun 01, 2026 - 15:30 EDT

Identified

We are currently investigating connection errors within our platform. Due to an upstream issue with our identity/login provider, users are experiencing issues once logged into the platform. This results in a "Connection Error" message when attempting to navigate the platform.

We will update this information once we are able!
Posted Jun 01, 2026 - 14:58 EDT
This incident affected: Energage Platform (Dashboard, Employer Recognition, Surveys, Insights, Employer Branding) and Energage Login.