Survey Incident
Incident Report for Energage
Resolved
This incident has been resolved.
Posted Jan 19, 2022 - 13:49 EST
Update
We are continuing to monitor for any further issues.
Posted Jan 19, 2022 - 12:06 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 19, 2022 - 11:56 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 19, 2022 - 10:45 EST
Update
We are continuing to investigate this issue.
Posted Jan 19, 2022 - 10:45 EST
Investigating
We are currently investigating an on-going issue.
Posted Jan 19, 2022 - 10:24 EST
This incident affected: Energage Platform (Dashboard, Employer Recognition, Surveys, Insights, Employer Branding) and Employee Survey, Subscription Management.