Survey Results tab inaccessible on Microsoft Internet Explorer
Incident Report for Energage
Resolved
The issue with the Results tab being inaccessible on Internet Explorer has been resolved.
Posted Jun 24, 2019 - 15:22 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 24, 2019 - 15:20 EDT
Identified
We have identified an issue with the Survey Reports tab being inaccessible in Internet Explorer. We are currently investigating this issue. Please check this page often for an updated status.
Posted Jun 24, 2019 - 15:15 EDT