Survey Access Issue
Incident Report for Energage
Resolved
This incident has been resolved.
Posted Oct 30, 2023 - 16:24 EDT
Investigating
We are currently investigating the issue and hope to have the system back up and running soon.
Posted Oct 30, 2023 - 16:07 EDT
This incident affected: Employee Survey, Energage Login and Energage Platform (Dashboard, Employer Recognition, Surveys, Insights, Employer Branding).