Energage Services impacted by a 3rd Party Outage

Incident Report for Energage

Resolved

This incident has been resolved. Thank you for your patience.
Posted Sep 16, 2023 - 18:37 EDT

Update

Our provider is continuing to restore service. We are monitoring the situation.
Posted Sep 16, 2023 - 17:49 EDT

Update

Our provider is continuing to restore service. We are monitoring the situation.
Posted Sep 16, 2023 - 13:08 EDT

Update

An infrastructure failure at our provider has been identified, the provider is working to restore service. Next update in 60 minutes.
Posted Sep 16, 2023 - 08:05 EDT

Identified

We are engaged with our vendor and will continue to provide updates.
Posted Sep 16, 2023 - 06:53 EDT
This incident affected: Employee Survey, Energage Login, Subscription Management and Energage Platform (Dashboard, Employer Recognition, Surveys, Insights, Employer Branding).