Slowness when accessing Employee Survey

Incident Report for Energage

Resolved

We have confirmed the fix and resolution. This incident is resolved. Thank you for your patience and happy surveying!
Posted Apr 27, 2026 - 11:41 EDT

Monitoring

A fix has been implemented, and we are monitoring the results. At this time, the employee survey is fully operational, and users should not experience any slowdown when accessing the application. We'll provide the all-clear once the fix is confirmed.
Posted Apr 27, 2026 - 11:01 EDT

Update

We are continuing to work on a fix for this issue.
Posted Apr 27, 2026 - 10:50 EDT

Identified

We have identified an issue that is causing significant slowness when users attempt to open an employee survey. We are actively working on the issue. We will provide updates as we work through the issue.
Posted Apr 27, 2026 - 10:20 EDT
This incident affected: Employee Survey and Energage Platform (Surveys).