Survey Outage (24 Feb 2020)
Incident Report for Energage
Resolved
This incident has been resolved.
Posted Feb 24, 2020 - 15:24 EST
Investigating
Our Survey application is currently experiencing issues. We are working as quickly as possible to identify and resolve the issue. Please contact your Customer Success representative with any questions or concerns.
Posted Feb 24, 2020 - 15:04 EST
This incident affected: Energage Platform (Employee Survey).