Platform Outage

Incident Report for Energage

Resolved

This incident has been resolved.
Posted Oct 23, 2024 - 08:40 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 23, 2024 - 08:04 EDT

Investigating

We are currently investigating the issue and working to get our systems back online.
Posted Oct 23, 2024 - 07:56 EDT
This incident affected: Employee Survey, Energage Login and Energage Platform (Dashboard, Employer Recognition, Surveys, Insights, Employer Branding).