Insights Outage
Incident Report for Energage
Resolved
The issue impacting access to Energage Insights has been resolved
Posted Mar 03, 2020 - 15:04 EST
Identified
We have identified an issue impacting the ability to access Energage Insights and we are working diligently to resolve this!
Posted Mar 03, 2020 - 14:56 EST
This incident affected: Energage Platform (Insights).