Energage Sites/Service slow for some users due to a third-party provider experiencing slowness

Incident Report for Energage

Resolved

This incident has been resolved.
Posted Dec 16, 2021 - 16:39 EST

Monitoring

Third-party provider are almost at normal speeds now. We are cautiously monitoring our Systems, which are generally usable at normal speeds.
Posted Dec 16, 2021 - 16:13 EST

Identified

The issue has been identified as a third-party provider, we are monitoring their status.
Posted Dec 16, 2021 - 15:39 EST
This incident affected: Energage Platform (Dashboard, Employer Recognition, Surveys, Insights, Employer Branding) and Energage Login, Subscription Management.