Survey Outage Identified

Incident Report for Energage

Resolved

This incident has been resolved.
Posted Oct 06, 2025 - 15:47 EDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 06, 2025 - 15:32 EDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 06, 2025 - 15:19 EDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 06, 2025 - 14:55 EDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 06, 2025 - 14:53 EDT

Identified

Our Employee Survey is currently experiencing a system issue. All employee surveys are currently affected. We have identified the issue and are quickly working toward a resolution. Please visit this page often for updates.
Posted Oct 06, 2025 - 14:52 EDT
This incident affected: Employee Survey and Energage Platform (Dashboard, Employer Recognition, Surveys, Insights, Employer Branding).