Energage Applications Experiencing Timeouts and Login Issues
Incident Report for Energage
Resolved
This incident has been resolved.
Posted Aug 31, 2021 - 19:52 EDT
Monitoring
Our key 3rd Party Providers are reporting Operational and our Issues appear to have resolved. We'll continue to monitor.
Posted Aug 31, 2021 - 16:51 EDT
Identified
Several of our 3rd Party Providers that rely on Amazon Web Services (AWS) are experiencing issue due to AWS itself experiencing a major outage.
Posted Aug 31, 2021 - 16:04 EDT
This incident affected: Energage Platform (Dashboard, Employer Recognition, Surveys, Insights, Employer Branding) and TopWorkplaces.com, Energage Login, Subscription Management.